PHP 5.6 og 7.0 snart End of Life

I December bliver det sidste chance for sikkerhedsopdateringer til de udbredte PHP versioner 5.6 og 7.0.

PHP 7.0 får senest sin sidste opdatering d. 3. December, 2018.
PHP 5.6 får senest sin sidste opdatering d. 31. December, 2018.

Dette vil sige at nye fejl der findes i selve server siden af PHP ikke længere vil blive rettet med nye opdateringer. Hvis man ønsker at fortsat holde sig sikker, foreslås det derfor at man opdaterer sin PHP version til 7.1 eller 7.2, som der har support i henholdsvis et og to år endnu.

Mere information om dette kan findes på PHP's side om understøttede versioner

Hvordan kan jeg finde min PHP version?

Hvis du er en webhotel kunde kan du i mange tilfælde gå ind i dit kontrolpanel og kigge efter PHP indstillinger. Her har du muligvis endda et valg du kan træffe vedrørende hvilken version du ønsker at bruge.

Hvis du ikke kan finde noget information af denne type kan du altid fremkalde phpinfo. Dette kan gøres ved at uploade en fil til din server med indholdet:

<?php
phpinfo();
?>

Upload denne fil under et vilkårligt navn og tilgå den i din browser.

Her vil du så se din PHP version i toppen af siden, sammen med en masse anden information om din PHP-opsætning.

PHPVersion

Jeg bruger version 5.6 (eller 7.0), hvad gør jeg?

Som nævnt før vil de fleste webhotel brugere have muligheden for at bruge en nyere PHP version. Hvis du ikke kan finde sådan en mulighed kan udbyderens support altid spørges.

På Rackhosting's webhoteller tilføjer vi jævnligt nye versioner af PHP, og har allerede installeret PHP 7.1 og 7.2 på vores servere for at være klar. Dette kan findes efter login under PHP Settings ved det enkelte domæne.

PHP
SelectPHP

Hvis du selv styrer din server og den software der er på den kan du være tvunget til enten at finde et andet sted at installere en nyere version af PHP fra, eller, alternativt, opdatere dit styresystem til en nyere version for at få det fra officielle kilder.

Hos Rackhosting er vi klar til at kunne yde assistance med at opgradere ældre PHP versioner. Hvis du ikke er sikker, eller ønsker at få opgraderet din PHP kan du tage kontakt til os igennem vores support på både telefon, ticket og chat.